[ANDROID][LINUX] Instalacja SDK, ADB i Fastboot w Ubuntu

Może Ci się również spodoba

  • Anonymous

    Dziękuję bardzo za Twój artykuł! Zatrzymałem się na „A teraz można wgrywać nowe ROMy na swoje telefony…” zanim wszystko wymażę 🙂 Co teraz zrobić, żeby z androida 1.5 przejść na 2.2? Mam HTC Magic z Orange Perfect SPL (SPL: 1.33.0010 a Radio: 3.22.20.171)? Rozumiem, że system.img i boot.img muszę skądś pobrać?

  • najpierw musisz skorzystać z programu który wgrywa obrazy z rozszerzeniem .kdz, żeby wgrać jakiś ROM z fastbootem (poczytaj na sieci, co to jest). A później możesz wgrywać co chcesz…

  • Tego właśnie szukałem, dzięki wielki za artykuł. Poniżej zamieszczam link z Romem 2.3 do GT540:
    http://forum.android.com.pl/f200/swiftdroid-v2-0rc4-by-mur4ik-cm7-download-i-faq-64284/

  • Chyba poprostu trzeba do odpowiedniego folderu wrzucic pliki system i boot a pozniej w konsoli wpisać komendy podane wyzej:0 nie pamietam juz ale chyba tak sie to robiło:)

  • Anonymous

    Witam odwiedzających, mam prośbę o pomoc w instalacji, posiadam telefon HTC i muszę skorzystać z punktu 4, i tu utknąłem a mianowicie po wpisaniu w konsoli polecenia:
    sudo echo ‚SUBSYSTEM==”usb”, ATTRS{idVendor}==”0bb4″, SYSFS{idProduct}==”61b4″, MODE=”0666″‚ >> /etc/udev/rules.d/51-android.rules sudo chmod 644 /etc/udev/rules.d/51-android.rules
    w odpowiedzi dostałem:
    bash: /etc/udev/rules.d/51-android.rules: Brak dostępu
    z gory dziękuję

  • wpisz najpierw sudo -i, a pózniej dokładnie to, co jest napisane (już jako root)

  • Anonymous

    wielkie dzięki, pomogło 🙂

  • Witam,

    Mi znowu coś takiego wyskoczyło

    root@olga-Aspire-1640:~# sudo touch /etc/udev/rules.d/51-android.rules
    root@olga-Aspire-1640:~# sudo echo ‚SUBSYSTEM==”usb”, ATTRS{idVendor}==”1004″, SYSFS{idProduct}==”61b4″, MODE=”0666″‚ >> /etc/udev/rules.d/51-android.rules sudo chmod 644 /etc/udev/rules.d/51-android.rules
    root@olga-Aspire-1640:~# sudo restart udev
    udev start/running, process 3775
    root@olga-Aspire-1640:~# sudo ./adb kill-server
    sudo: ./adb: nie znaleziono polecenia
    root@olga-Aspire-1640:~# sudo ./adb start-server

    POMOCY

  • @Łukasz: czy na pewno jesteś w folderze, w którym jest binarka adb?

  • Witam. poczatek jest ok. ./adb devices. wykrywa mi ciag znakow i recovery, czyli telefon w trybie recovery,albo w trybie device jak reboot z konsoli robilem. chmod 777 idzie.wszystko robie na roocie. wpisuje ./fastboot -w. i mam co jest nie tak? zrozumialem tyle ze wszystko jest ok tylko nie wykrywa moze urzadzenia do konca. robione na Fedora 19,XFCE. z gory dziekuje za pomoc 😉